NiFi versions and remote process groups

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

NiFi versions and remote process groups

Russell Bateman
Should I be able to wire a remote process group on a NiFi 1.0.0 canvas to an input port on a 0.7.1 canvas? (Neither is a cluster.)

I have an input port in 0.7.1, but when I click the "circle-arrow" icon on my NiFi 1.0.0 remote process group and drag it, I get

'NiFi Flow' does not have any output ports (true, it doesn't)
'NiFi Flow' does not have any input ports (false, there is one).

When I try to connect the output of a processor in my NiFi 1.0.0 instance, I also get
'NiFi Flow' does not have any input ports.

I presume 'NiFi Flow' refers to my running NiFi 0.7.1 instance (since that's its name in the title bar of the browser).

I've examined:
https://nifi.apache.org/docs/nifi-docs/html/user-guide.html#Remote_Group_Transmission
https://nifi.apache.org/docs/nifi-docs/html/user-guide.html#site-to-site
https://community.hortonworks.com/articles/16461/nifi-understanding-how-to-use-process-groups-and-r.html
Thanks.
Reply | Threaded
Open this post in threaded view
|

Re: NiFi versions and remote process groups

Koji Kawamura
Hello Russell,

You should be able to connect NiFi 1.0.0 to NiFi 0.7.1 via RemoteProcessGroup.
Please check this Gist, I confirmed that it works:
https://gist.github.com/ijokarumawak/37e428d5be8ce8031220f87c5ee9601c

Did you wait for a while and refresh the canvas and RemoteProcessGroup
on NiFI 1.0? Sometimes it takes a while for the RPG to recognize
remote ports availability due to its async nature.

Thanks,
Koji

On Thu, Nov 17, 2016 at 6:56 AM, Russell Bateman
<[hidden email]> wrote:

> Should I be able to wire a remote process group on a NiFi 1.0.0 canvas to an
> input port on a 0.7.1 canvas? (Neither is a cluster.)
>
> I have an input port in 0.7.1, but when I click the "circle-arrow" icon on
> my NiFi 1.0.0 remote process group and drag it, I get
>
> 'NiFi Flow' does not have any output ports (true, it doesn't)
> 'NiFi Flow' does not have any input ports (false, there is one).
>
> When I try to connect the output of a processor in my NiFi 1.0.0 instance, I
> also get
> 'NiFi Flow' does not have any input ports.
>
> I presume 'NiFi Flow' refers to my running NiFi 0.7.1 instance (since that's
> its name in the title bar of the browser).
>
> I've examined:
>
> https://nifi.apache.org/docs/nifi-docs/html/user-guide.html#Remote_Group_Transmission
> https://nifi.apache.org/docs/nifi-docs/html/user-guide.html#site-to-site
> https://community.hortonworks.com/articles/16461/nifi-understanding-how-to-use-process-groups-and-r.html
>
> Thanks.